Results 1 to 3 of 3
  1. #1
    Junoir Member
    Join Date
    Nov 2017
    Yes I Do
    Rep Power

    Problem with Addon

    Hello there,

    I have Kodi version 17.3 on my Nvidia Shield. I want to install an addon named "Fantastic". I installed it first, then tried to run but the screen just flashed and took me out to the Kodi main screen. Sometimes, it has also taken me out to the app menu screen. But when I tried the second time, it is giving me the "Failed to install dependency" Error.

    Kindly suggest me a good and an effective fix.


  2. #2
    Readings Master
    Join Date
    Feb 2016
    yes i do
    Rep Power
    You should always install this type of add-on, by installing the Repository which will include the required Dependent Programs.

    How To Install Fantastic HD On Kodi Guide

    Launch Kodi
    Click the settings icon Kodi Settings Icon
    Click System settings
    Hover over Add-ons menu item and turn on Unknown sources if not already on
    Click back on remote to go back to System page
    Click File Manager
    Click Add source
    Click <None>
    Type the following url exactly how it is listed here –

    and click OK
    Highlight the box under the source that you just typed in and enter a name for this media source, type Fire or any other name you would like to identify this source as and click OK
    Click your back button on remote or keyboard until you are back at the Kodi home screen
    Click Add-ons menu item
    Click the small “open box” icon at top left side of page under the “Add-ons heading” Install Kodi Addon
    Click Install from zip file
    Click Fire or other name you assigned the media source in previous step
    Wait for Firestickplusman Repo add-on enabled message to appear
    Click Install from Repository
    Click Firestickplusman Addons
    Click Video add-ons
    Click Fantastic
    Click Install
    Wait until you see Fantastic Add-on installed message
    You have installed Fantastic HD!

    Last edited by ilan; 11-27-2017 at 07:22 PM. Reason: Coded link

  3. #3
    Junoir Member
    Join Date
    Nov 2017
    Yes I Do
    Rep Power
    aaa OKay... Let's give it a try. I hope this works kz If it didn't, then Hard Reset will be the Final Option

    Best Regards Brother.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts